System Requirements

Below are the minimum requirements to run PlanSwift as well as recommendations for improved performance.

For additional requirements related to installing and upgrading PlanSwift, see: Installing PlanSwift and Check for and Install PlanSwift Updates.

PlanSwift is designed for and tested on US-English versions of Windows®. There may be minor display issues when installed on other regional versions of Windows.

PlanSwift is designed for and tested on Professional and Enterprise editions of Windows®. We do not test on “Home” editions or other non-business-level editions of Windows and cannot guarantee that your will be able to install or run PlanSwift on any editions other than Professional and Enterprise.

As of 10/1/2022, PlanSwift versions older than 10.1 (including all versions 9 and 8) will be discontinued - you will no longer be able to download or activate these versions, see PlanSwift Sunsetting Policy (Product End of Life) for more information.

Minimum Requirements to Run PlanSwift 10 and PlanSwift 11

Windows® Operating System

Recommended: Windows 10 Pro or Enterprise, 64-bit (all Windows updates must be installed)

Minimum: Windows 10 Pro or Enterprise, 32-bit (supported but addresses 3GB of RAM or less)

As of 9/8/2022, PlanSwift 11 is available to all users under a current maintenance agreement. PlanSwift 11 is supported on Windows 11, although we are still listing Windows 10 as our "Recommended" OS, just until Windows 11 has a bit more "shakedown" time.

Processor

Recommended: Intel i5 or i7, 2.33GHz , 6MB L2 cache 1333MHz front-side bus or better, 64-Bit

Minimum: Intel or AMD Dual-Core or better 32-Bit / 2.6GHz

Memory

Recommended: 8GB or more DDR3 or faster

Minimum: 4GB

Monitor/Resolution

Recommended: 1280 x 1024 or higher and support for multiple monitors

Minimum: Super VGA (1024x768)

Graphics

Recommended: 1GB+ dedicated graphics memory

Minimum: 512MB dedicated graphic card

Free Hard Drive Space

Recommended: 256+ GB SSD

Minimum: 10GB

Internet Connection

An unrestricted connection is required for Activating the product, receiving updates, viewing the help files, etc. The speed at which you can download plans from a Planroom and sending/receiving project information via 'Email Job' is limited by your internet bandwidth.
Web BrowserAny current browser. We recommend Microsoft Edge or Google Chrome.


Additional Software

To use the Excel functions, a local-installation of a supported version of Microsoft® Excel® (see Microsoft's website for details on which versions of Excel are supported: https://support.microsoft.com/en-us/lifecycle/selectindex). 
Microsoft® Outlook® for exporting/sending projects to other users.

Windows 7, 8, and 8.1

Please Note, Windows 7 and Windows 8 are no longer supported by Microsoft. In accordance with our Sunsetting policy linked below, PlanSwift no longer tests our software on these operating system.

As the number of Windows 8.1 users is very low, PlanSwift has decided to focus our testing efforts on Windows 10 and 11 only.


Notes

The Minimum requirements support basic program functionality, however they likely will not provide insufficient resources to use all available features and may cause unacceptable performance. To get the best performance, we suggest your hardware meet or exceed "Recommended". 

The Current version of PlanSwift is compatible with both 32- and 64-bit Windows® Operating Systems however 32-bit operating system are limited to the amount of RAM they can address.

PlanSwift has known issues with being installed to a Server or Remote Desktop environment and we are unable to provide support for issues related to installation in these environments. 

PlanSwift cannot be installed directly on a MAC, you must use Bootcamp (dual-boot) or install PlanSwift in a virtual machine such as Parallels running a supported version of Windows. See Can I Install PlanSwift on a Mac?

Sunsetting/End-of-Life

Over the years, both PlanSwift and Microsoft have developed and released new versions of their software. For our policy on which versions of PlanSwift are supported and for how long, see PlanSwift Sunsetting Policy (Product End of Life) .

PlanSwift supports our software installed and operated only on versions of Windows currently under "Mainstream Support" with Microsoft. When a version of Windows is 'retired' by Microsoft, products that were limited to installation on that operating system (or earlier ones) only are no longer supported by PlanSwift. Products limited to Windows versions that fall of "Extended Support" with Microsoft will no longer be distributed. If your version is no longer supported or is limited to a Windows operating system version that is no longer supported by Microsoft, please contact Customer Success at 866-627-6246 to discuss your options.

PlanSwift Sunsetting Policy (Product End of Life)

Installing PlanSwift

Specs to Build Your Own High Performance Workstation